首页 > Linux监控管理 > Default Problem with zabbix mysql install

Default Problem with zabbix mysql install

2016年11月25日

Default Problem with zabbix mysql install

https://www.zabbix.com/forum/showthread.php?t=44965

I try to install ZABBIX with tut: https://www.zabbix.com/documentation…_from_packages
But in this step:

PHP Code:
# apt-get install zabbix-server-mysql zabbix-frontend-php

I get error:

PHP Code:
The following packages have unmet dependencies:
zabbix-server-mysql : Depends: libsnmp15 (>= 5.4.3~dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.

Then, i install libsnmp15, but it shows:

PHP Code:
Package libsnmp15 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libsnmp30:i386 libsnmp30 libsnmp-base
E: Package ‘libsnmp15’ has no installation candidate

I use ubuntu 13.10, and already installed libsnmp30, Zabbix require libsnmp15.

Any solutions for me?

 

 

 

Try installing this:
Code:
sudo apt-get install libsnmp-dev
then run again
Code:
# apt-get install zabbix-server-mysql zabbix-frontend-php
and see if it helps.

I wonder what is causing this issue. I could successfully accomplish this task yesterday on my virtual Ubuntu 13.10 desktop.

Is your Ubuntu up to date?

Code:
sudo apt-get update && sudo apt-get upgrade

 

 

 

wget http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_3.0-1+xenial_all.deb

dpkg -i zabbix-release_3.0-1+xenial_all.deb

 

分类: Linux监控管理 标签:
本文的评论功能被关闭了.