首页 > Linux故障排查, Ubuntu/Debian操作系统 > Unable to correct problems, you have held broken packages

Unable to correct problems, you have held broken packages

2016年11月25日

Unable to correct problems, you have held broken packages

http://www.linuxquestions.org/questions/linux-desktop-74/unable-to-correct-problems-you-have-held-broken-packages-4175510237/

Hey forum I wanted to run some applications that required Gnome (wouldn’t run on unity) I thought what I was doing was installing Gnome as an option to run by selecting it at the login screen. Unfortunatly I now have no unity option. Default is now Gnome and unity-desktop will NOT reinstall.

I have gnome(default), XBMC, & Cinnamon for options

I have searched all over and found nothing that has worked! I am ready to just start over but would love to fix it instead

Terminal output:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ubuntu-desktop : Depends: ubuntu-session but it is not going to be installed
Depends: unity-control-center but it is not going to be installed
Depends: unity-settings-daemon but it is not going to be installed
Recommends: xul-ext-webaccounts but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 

sudo apt-get update && sudo apt-get upgrade
本文的评论功能被关闭了.