首页 > Ruby/Rails开发 > rails开发记录

rails开发记录

2016年5月15日

rails开发记录

http://www.codeweblog.com/rails开发记录/

安装rvm(rvm => ‘Ruby Version Manager’) 官网地址:https://rvm.io/

终端运行命令:

$ \curl -#L https://get.rvm.io | bash -s stable

或者安装 jewelrybox(rvm的图形客户端),官网地址: http://jewelrybox.unfiniti.com/

rvm install 1.9.3 --安装ruby1.9.3
gem install rails --安装rails

如果rvm没有加入path,删除${user.home}中的 .zprofile 和 .zshrc 两个文件后重新安装。

如果系统中没有编译器,需要安装xcode的Command Line Tools或者通过brew安装apple-gcc

brew :http://mxcl.github.com/homebrew/

brew update
brew tap homebrew/dupes
brew install apple-gcc42

进入workspace,新建项目

rails new appName -d mysql --skip-bundle #指定数据库为mysql,跳过bundle步骤
#修改生成的项目文件中的Gemfile,将第一行
source 'https://rubygems.org'
#替换为淘宝镜像
source 'http://ruby.taobao.org'
清除控制台中多余的304日志,在Gemfile中加入:
# 去掉访问日志
group :development do
  gem 'thin'
  gem 'quiet_assets'
end

然后运行 bundle install 安装gem

修改config/database.yml中的数据库配置

然后运行 rake db:create 创建相关的数据库

Library not loaded: libmysqlclient.18.dylib错误解决办法:

add the library path in your ~/.bash_profile or ~/.profile:

MYSQL=/usr/local/mysql/bin
export PATH=$PATH:$MYSQL
export DYLD_LIBRARY_PATH=/usr/local/mysql/lib:$DYLD_LIBRARY_PATH
加入 Twitter Bootstrap 支持
Gemfile中添加

group :assets do
  gem 'therubyracer', :platforms => :ruby
  gem 'twitter-bootstrap-rails'
  gem "less-rails"
end
依次运行
bundle install
rails generate bootstrap:install less
rails g bootstrap:layout application fixed

twitter bootstrap的更多gem介绍:http://railsapps.github.com/twitter-bootstrap-rails.html

==end== 2013-03-26 17:36:12 updated

分类: Ruby/Rails开发 标签:
本文的评论功能被关闭了.