首页 > Linux故障排查 > E: Unable to correct problems, you have held broken packages. .

E: Unable to correct problems, you have held broken packages. .

2015年10月16日

E: Unable to correct problems, you have held broken packages.   .

http://blog.csdn.net/npjocj/article/details/18985267

E: Unable to correct problems, you have held broken packages. – 衰人有里 – 博客频道 – CSDN.NET

在安装RVM来管理ruby时遇到一些库的版本问题
The following packages have unmet dependencies:
libreadline6-dev : Depends: libreadline6 (= 6.2-8) but 6.2-9 is to be installed
E: Unable to correct problems, you have held broken packages.

解决:

  1. aptitude install libreadline6-dev
aptitude install libreadline6-dev

The following NEW packages will be installed:
libreadline6-dev{b}
0 packages upgraded, 1 newly installed, 0 to remove and 137 not upgraded.
Need to get 264 kB of archives. After unpacking 802 kB will be used.
The following packages have unmet dependencies:
libreadline6-dev : Depends: libreadline6 (= 6.2-8) but 6.2-9 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1)     libreadline6-dev [Not Installed]

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Downgrade the following packages:
1)     libreadline6 [6.2-9 (now) -> 6.2-8 (precise)]

Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
libreadline6
The following NEW packages will be installed:
libreadline6-dev

分类: Linux故障排查 标签:
本文的评论功能被关闭了.