首页 > Python编程 > 使用国内镜像通过pip安装python的一些包

使用国内镜像通过pip安装python的一些包

2015年9月8日

使用国内镜像通过pip安装python的一些包
http://blog.csdn.net/sasoritattoo/article/details/10020547

学习flask,安装virtualenv环境,这些带都ok,但是一安装包总是出错无法安装,
http://e.pypi.python.org/这个就是官网了,清华大学提供的
建议非清华大学校内的使用这个镜像: http://e.pypi.python.org/simple(这也是一个http://pypi.v2ex.com/simple),清华校内的就使用这个:http://mirrors.tuna.tsinghua.edu.cn/pypi/simple

使用镜像的方法可以在每次执行pip的时候加上参数”-i http://e.pypi.python.org/simple”即可,
或者也可以在本地配置,这样就不用每次都加上参数了,应用Cheer Xiao的配置(http://blog.makto.me/post/2012-11-01/pypi-mirror):
[plain] view plaincopy在CODE上查看代码片派生到我的代码片
使用pip的用户可以如下配置:

在unix和macos,配置文件为:$HOME/.pip/pip.conf
在windows上,配置文件为:%HOME%\pip\pip.ini

需要在配置文件内加上:

[global]
index-url=http://mirrors.tuna.tsinghua.edu.cn/pypi/simple
还有一个小技巧,就是把所有要安装的包写在一个文件里面,比如requirement.txt(每个包写一行,顶行头写),然后pip安装的时候只需要加参数“-r requirement.txt”即可。

安装好之后体验了一把,速度飕飕的~~

ps:
使用步骤:
1.进入目录下使用命令:virtualenv env
2.source env/bin/activate,这时候你会发现命令行前面会多出个(env)标识,这表明你已经进入了虚拟环境了。
写个简单的hello.py验证:
[python] view plaincopy在CODE上查看代码片派生到我的代码片
#!/usr/bin/python
from flask import Flask

app = Flask(__name__)

@app.route(‘/’, methods = [‘GET’, ‘POST’])
def hello():
return ‘Hello world!’

if __name__ == ‘__main__’:
app.run()
提示没有flask包,使用上面的方法pip之,pip install -i http://e.pypi.python.org/simple flask,速度超快,安装之,运行,OK。
解惑:为什么这样安装酒OK了?而且不会对系统的原有的包造成影响?
查看env目录下的内容,发现在env/lib/pythonX.X/site-packages目录下有这些安装的包,比如我的下面有这些:
[plain] view plaincopy在CODE上查看代码片派生到我的代码片
distribute-0.6.24-py2.7.egg itsdangerous-0.23-py2.7.egg-info Jinja2-2.7.1-py2.7.egg-info setuptools.pth
easy-install.pth itsdangerous.py markupsafe werkzeug
flask itsdangerous.pyc MarkupSafe-0.18-py2.7.egg-info Werkzeug-0.9.3-py2.7.egg-info
Flask-0.10.1-py2.7.egg-info jinja2 pip-1.1-py2.7.egg

这就是虚拟机的作用了。
终于可以安心的把精力集中到flask上了。

#2013.08.27
直接安装flask会安装最新0.10的版本,很悲剧的是很多扩展包还没跟上此版本,所以很多功能没法用哦~~比如Falsk-Mail的版本
所以还是重新安装Flask的0.9版本,不过这也不是个事,有了envitualenv后环境非常容易,今天试了 -i http://e.pypi.python.org/simple竟然不行了 = =!,找到这个镜像地址不错http://pypi.v2ex.com/simple
哦,安装Flask0.9版本也很容易,直接pip install Flask==0.9即可。

分类: Python编程 标签:
本文的评论功能被关闭了.